VS 2015

May 4, 2015 at 10:34 AM
Dobrý den,

bylo by možné vyrobit instalační balíček s podporou VS 2015?
May 4, 2015 at 11:50 AM

if you don't mind, let's switch from our native language to the language people usually understand :). I will modify the installer shortly and if there are no compatibility issues, I'll also update the Visual Localizer release. I'd be gratefull for any feedback since I currently have very limited time to test if all works well in the new VS.


May 4, 2015 at 1:07 PM
Hi again,

would you kindly check the installer http://download-codeplex.sec.s-msft.com/Download?ProjectName=visuallocalizer&DownloadId=1454283 if it works for you? I cannot get VS 2015 working myself to test it...

May 5, 2015 at 9:17 AM

I'm sorry but it's not working. First, the installer's "Integration" screen shows just choices(checkboxes) "VS 2008","VS 2010","VS 20012","VS 2013", tt makes me a bit confused :), but there is anotther "Integration" screen following, with one "VS 2015" checkbox, so that's fine.
But start of VS 2015 crashes with this message:
May 5, 2015 at 11:28 AM

the thing with the installer - that's by design. Amazingly, VS only provides screen consisting of 4 checkboxes :). Didn't have time to find a workaround.
The error you getting is weird. You can remove it by uninstalling Visual Localizer. Could you try running the following command please?
1) navigate to VS 2015 installation folder /Common7/IDE
2) run devenv.exe /setup from console
Try running this, then uninstall Visual Localizer and try it again. I'd be grateful if you sent me the output of both attempts.

May 5, 2015 at 11:55 AM
I tried your steps.
The result is pretty the same. There's more findings:
  • I've both vs2013 and vs2015 installed, new version works ok in vs2013, not working in vs2015
  • when I start vs2015 ide, there's no error yet. Error message appears when I try open project or create new project. Then "...package did not load correctly..." exception is raised.
I dont want to push you, but VS 2015 RC is free for download & try at Microsoft pages :)
May 5, 2015 at 1:20 PM
I found the bug and updated the release - please uninstall the buggy version a download a new one. It should work.

May 5, 2015 at 2:05 PM
I tried, its way better :)
There is no exception, so it looks fine, but I cant see any popup-menu command of Localizer :(
There is "Visual Localizer" context menu in VS2013 (with submenu eg Move to resources, Inline, ...)
But there is no "Visual Localizer" context menu in VS2015. Can I switch-on something somewhere to get it work..?
May 5, 2015 at 2:10 PM
It is possible that you disabled the package. Please run "devenv.exe /resetskippkgs" (it will start VS, Visual Localizer should be included). After that, you can start VS normally.
May 5, 2015 at 2:15 PM
yes, my fault.
ok, i did reset, now I have exception back.
here's part of ActivityLog.xml :
<time>2015/05/05 13:12:39.428</time>
<description>Begin package load [VisualLocalizer.VisualLocalizerPackage, VisualLocalizer, Version=, Culture=neutral, PublicKeyToken=75f9cf9fcef5fca3]</description>
<time>2015/05/05 13:12:39.428</time>
<description>CreateInstance failed for package [VisualLocalizer.VisualLocalizerPackage, VisualLocalizer, Version=, Culture=neutral, PublicKeyToken=75f9cf9fcef5fca3]</description>
<errorinfo>Could not load file or assembly 'file:///c:\VisualLocalizer.dll' or one of its dependencies. Systém nemůže nalézt uvedený soubor.</errorinfo>
May 5, 2015 at 2:20 PM
That looks like the old buggy version. Are you sure you uninstalled it and installed the new one properly? To be on a safe side, try the following:

1) uninstal Visual Localizer
2) run devenv.exe /setup
3) install new version of Visual Localizer
4) run devenv.exe /setup again
5) run devenv.exe /resetskippkgs again

Also, if it's possible, keep the default installation path.
May 5, 2015 at 8:35 PM
It works :)
(ver 1.3.8)

So, thanks.
May 5, 2015 at 8:50 PM
Happy to help, thanks for the review :)